0

my Compaq 2700us has been giving me fits...

i decided to use the quickrestore cd to wipe and reinstall XP (just to 'clean house'). I had no Stop errors prior to this. The QuickRestore CDs copy all the image file to the HDD, then when rebooting i recieve the following stop code as XP boots for the first time:

Invalid_work_queue_item

1) stop: 0x00000096 (0X80eeb110, 0x8054acb, 0x80548a80, 0x80571358)
2) stop: 0x00000096 (0x80f5b530, " , " , " )

i also get an

Irq_not_less_or_equal

stop: 0x0000000A (0x00000004, 0x00000002, 0x00000001, 0x804f7366)

each of these occur after loading of agp440.sys file, (i assume this is when the XP gui starts)..... since this is a laptop no hardware changes have occured, i'm unsure what caused the OS to fail initially, but since i cannot complete setup of XP, i cannot boot into safe mode and have no way of accessing the dump files. So after low-level formatting the HDD, i've been able to load win98 on it and have no problems... i'm using the laptop to log on and write this.... i've tested the memory with various programs > 12 hrs each time w/ no errors detected in the ram.

any thoughts or advice??? i miss XP

thanks

2
Contributors
11
Replies
12
Views
10 Years
Discussion Span
Last Post by bigozone
Featured Replies
  • [QUOTE=bigozone;470554].... BTW my BIOS is very limited, i can choose boot devices, set time and date, and enable/disable USB legacy and the on-board NIC. That's all of the options this COMPAQ bios has choices for.... what a POS![/QUOTE] Best of luck. I'm really surprised that the COmpaq BIOS doesn't enable … Read More

0

Can you boot into safe mode and do stuff?

When was this laptop made? I suspect it was pre SP2. The wisdom seems to be that if you can get hold of the SP2 disk (that came out with many mags a couple of years ago), or download & install it from Microsoft in Safe Mode, then your problem could be solved.

0

no I can't do anything when booting in safemode ...... the OS tells me
"setup was not completed"
"rerun setup"
the cursor then stops moving after clicking on either the OK button or the X to close the message window.....

My main problem is the Compac Quick restore CDs don't have the XP setup program,,, instead it contains an IMAGE of hard-drive as it looked when purchased.... (OS & all preloaded software). basicly i have no XP CD and no way to run XP setup.... i'm going to try using a friend's XP CD to install the OS... something about the image file is conflicting with the laptop, (my guess is an updated bios that was installed long ago) the really confusing thing is i used the Quick Restore CDs about 2 months ago and since then i've not had any hardware changes or bios updates.

thanks for your suggestion, i guess i'll try that when i get the XP CD

0

If I recall correctly, the Compaq restore CD is a self contained boot environment but it doesn't let you get into command mode.

But if you have a second PC, you could make a bootable CD with FDISK and Format etc.

Your friend's XP CD should, of course, get you to that point and then you can zap the HDD and hopefully restore from the restore disk.

I'd never be wothout a second PC and I keep all my old laptops.

Keep us posted.

0

I was thinking also about this AGP440.sys file.

Microsoft published something about this: http://support.microsoft.com/kb/324764

You've probably read it. But it occurred to me that you could try booting with the step-by-step option, and when it asks you to confirm AGP440.sys, say NO. As you're in Safe Mode, I'm reasonably sure that the default 640 x 480 driver in Windows will take care of the screen; if you're not in safe mode, then the standard Windows driver should pick the screen up, albeit with slow scrolling speed.

0

And another thought -

If it's got past AGP440.sys, it could be the next files in sequence. What would those be? ACPI? In which case you could try and disable power management in the BIOS.

What are the next SYS files to be loaded after AGP440.sys?

0

thanks for your info.... i'm glad i don't have any cash invested in the laptop... if i had payed for it, i don't think i'd buy a COMPAQ.
anyway, the compaq restore CDs won't let me do any thing but reinstall the IMAGE.... and even after LOW LEVEL FORMAT the restore cds install, but when it reboots and it should go to the part of XP setup where i am asked to pick my language and time zone, it fails to load to that screen and instead gives me the BSOD from my first post...

but i've got an XP CD and am currently formatting the HDD from within the XP setup.

crossing my fingers, I hope the install completes w/o giving me those d@mn BSOD stop codes....

i'll post results soon'

once again thanks.

BTW my BIOS is very limited, i can choose boot devices, set time and date, and enable/disable USB legacy and the on-board NIC. That's all of the options this COMPAQ bios has choices for.... what a POS!

1

....

BTW my BIOS is very limited, i can choose boot devices, set time and date, and enable/disable USB legacy and the on-board NIC. That's all of the options this COMPAQ bios has choices for.... what a POS!

Best of luck.

I'm really surprised that the COmpaq BIOS doesn't enable you to disable power management (whether or not it's called ACPI by Compaq I don't know).

Votes + Comments
thanks for your time and advice...
0

no power managmnet or acpi in BIOS...

the XP disk I borrowed from a neighbor goes thru the setup and after setting timezome and time when i click OK it works for a few seconds and then gives me the exact same errors... i'm beginning to think i may have bad ram or a bad HDD....

i'll post a solution IF I FIND ONE!

0

after much toil and trouble, i finally reflashed the bios ( to the same version, but using a new disk),,

i guess the bios was corrupted by a problem with the original flash update.
it makes no sense, if the loaded bios file was not correct it should have failed the CRC check or failed to update.

a simple BIOS Flash was the answer all along

thanks to all for thier time and info

0

Well done. Hope my advice was of some help. It did seem to me to be a BIOS problem. The flash probbly loaded the functionality.

Anyway, do please mark this thread as SOLVED.

0

i had to reload to win98 just to be able to download the flash. Then booting to COMMAND PROMPT ONLY, I flashed the BIOS.... Next i tried the Quick Restore disks again. Success, finally it worked, but what a pain, I can't see a end-user trying to jump thru those hoops to get the OS reinstalled.


thanks to all for your help

the machine is still working well for a Campaq especially considering that it now belongs to my 8 yr old niece. that poor pc has been droped more scince christmas than a consumer-reports test machine... LOL

later

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.