0

I have a Windows Server running and i need to assign a static public ip through DD-WRT to it, so my remote desktop users can still access it via that, however I am coming up with nothing after scowering the DD-WRT website.

3
Contributors
3
Replies
4
Views
6 Years
Discussion Span
Last Post by montelaphone
0

What you need to do is add the port 3389 to the DMZ and point it toward the server that needs to be available. The router will let one host normally be available to the outside on specific ports. Look up DMZ in your router docs.

0

This still doesn't allow the outside world to access my server via one of the 5 static public ip's i purchased. Also this creates a security risk since it forwards all ports not just the one i want opened for rdp(3389)

0

You could diable NAT and assign your public address as your router's address. For instance, if your WAN Ip range was 1.1.1.1/29 with 5 useable (excluding your WAN IP), in the basic setup under net work setup you would enter the following.

Local IP address: for example 1.1.1.7 which would be the same as your router's public IP.
Subnet Mask: 255.255.255.248
Gateway:1.1.1.7
DNS: you may need to enter your ISP's DNS server/s

Once you have saved this you then need to disable nat by going to Advanced routing and selecting "Router" under operating mode. Save and apply

If you've left DHC enabled all the network devices connected to the router should be assigned one of the 5 available public addresses (1.1.1.2 - 1.1.1.6), otherwise you can manually assign these on each device.

Ofcourse another option would be to use PAT and translate alternative ports such as 3390,3391,3392, etc to 3389 and send these to the relevant private IP's.

Now if someone could help me set up routed with NAT on the same firmware I'd be a very happy man :D

Edited by montelaphone: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.