Start New Discussion within our Networking Community

I am not able to load the yahoo sites (yahoomail, yahoo,yahoo answers etc) and few other sites(eg
Please refer to my earlier post :
I had a Beetel 450TC1 router, which finaly gave up yesterday, so I used the modem that my ISP provided, a wire-only router (AN1020-20) and these sites were working. So I got a new router - TP-LINK, TLWR740N, and the issue is back.
I have a desktop, that is connected through wire to the router, a laptop, a tablet and a few handsets that connect wirelessly to the router. None of these devices can browse the yahoo sites.
I can still access the sites through the wired router(AN1020-20) on the desktop and laptop, and can access the sites on the handheld devices through 3G.
I have done all the troubleshooting I could think off....
- I have Changed the DNS to the google public dns, this loads the yahoomail page partially, but after providing the credentials, the page keeps loading.
- Turned off firewall, no success.
- Turned off the UPnP, no success.

Please help.

Check the routers for the newest firmware just to cover any software bugs.

Turn off all Intrustion Detection systems on the router (if any).
Turn off all firewall features on the router (if Any)
Remove any blocked keywords if your router has that feature (remember block the word 'sex' and will also be blocked.

Just found that there was a Diagnostic Section in the Router's page, which allows to ping and traceroute.
I pinged,and the result is pasted below :
Pinging [] with 64 bytes of data:

Reply from bytes=64 time=335 TTL=49 seq=1
Reply from bytes=64 time=434 TTL=49 seq=2
Reply from bytes=64 time=341 TTL=49 seq=3
Reply from bytes=64 time=371 TTL=49 seq=4

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milliseconds:
Minimum = 335, Maximum = 434, Average = 370

Out of curiosity I pinged from the command promt and the result is :

Pinging [] with 32 bytes of data:
Reply from bytes=32 time=310ms TTL=49
Reply from bytes=32 time=310ms TTL=49
Reply from bytes=32 time=310ms TTL=49
Reply from bytes=32 time=313ms TTL=49

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 310ms, Maximum = 313ms, Average = 310ms

I am really clueless at this point,i can successfully ping the sites but cannot browse them...
serious help needed!!!

What is your current OS that you are running on the computer?

Have you tired accessing the sites using hexidecimal or binary this can sometimes identify some ossue with the name resolutions and can also help you see if it your router that is locking them for any reason?

please bachack. What did you do to solvethat problem. I am ahving the same issue, not being able to access secure sites with tl-wr740n. thanks in advance

I was interested in the answer to this problem also. I have to do frequent work on different types of routers. Friends, family, aquaintances, etc. Including my own network modem/router on which I have 4 pc's. Two wired and two wireless. I thought finding and joining this site was a great move forward for learning, sharing, solving pc tech problems. But it seems some do not like to share.

i think beetal do not provide that good net connecting services..
use tata docomo or internet connections..!!

go to or whchever is der for you

then go to network -> WAN -> advance -> Change the MTU size to 576 then save it and reboot it

hope this will work. This is workd fr me.

Email me if the result is positive -

This question has already been answered. Start a new discussion instead.