Hi, been on windows vista home premium for 9 months & have occasionally tried to find out how to send a web page link to the desktop & haven't yet discovered how to! With XP it was simply a case of going to 'file', then 'send link to', & then choosing 'desktop'. I've seen an old post that suggests going to 'tools', 'tool bars', then 'classic menu'. This function is nowhere to be seen!

I bet the answer is simple! I know there's bookmarks to use, but occasionally it's obvious that it's nice to have web links on the desktop pertaining to a separate topic or for business etc. Thought I'd overcome silly problems after all this time! but it's beaten me has this!

Cheers

I assume you are using IE as your browser. Right click where you have your links saved up at the top of the browser, where you would normally see file, edit, view etc.. Then choose menu bar. From there you go to file, send, desktop.

Sorry, forgot to mention i'm using firefox browser & this could mean i'm blaming vista wrongly & that it's a query about firefox? I've just found a way of sending a web page link to the desktop by firstly adding the site to bookmarks, then copying it FROM bookmarks, & then pasting it onto desktop. Then having to go back to bookmarks to delete the original copy because i don't want it in there!

There must be a quicker and easier way of doing this, does anyone know?
Thanks

File -> Save Page As -> Browse to desktop

Sorry, I've not been helpful (with not putting everything in the 1st post). Yes, using 'save page as' does work as per usual, but that way also brings along extra clutter with 2 to 5 other icons & folders including the shortcut. If I delete any part of the clutter then the shortcut deletes too. I was just hoping there was a simple way of saving JUST a shortcut on its own like with IE. Yes I've discovered a way to do this as described in post 3 but that seems an odd way for such a simple task!

Right click on the link & copy the shortcut.

Point mouse at Desktop, right click and paste.

Or have I misunderstood?

Do you mean right click on the address bar url? Or which link do you refer to? If i copy the web address from the address bar the paste is not functional for it to be pated onto the desktop. I can create a folder on the desktop & it will paste in there, but it also pastes the 'baggage' to do with that site & you sometimes get up to 4 items alongide each other. There must be an easier way! In IE it was so EASY! Tools, 'send shortcut to desktop).

I can only speak for IE. I can right click on any link, select Copy and then Paste Shortcut onto the Desktop. Vista Home Premium.

Yes it's easy with IE. But with Firefox it lets you copy the link but on the drop down menu the 'paste shortcut' is blanked out. Maybe i'm copying the wrong thing? I'm copying the url address at the top where you type in the site addresses. When you say you can click on any link.......exactly what links do you refer to? I see no links anywhere on the internet! I see millions of web pages with information & links to other sites or pages for that site. But what i want to do is paste a shortcut tho the webpage i'm actually looking at. "Save as'....only saves the content into word doc or wherever, it doesn't save it as a shrtcut link!

OK - I'm with you now. The URL address box in IE behaves in the same way. If you copy the URL and right click on the desktop, it won't offer Paste or Paste Shortcut. Right click in a document allows Paste.

I can only imagine that this is because Windows has to know about the object copied onto the clipboard; the Address box is text that is parsed when you hit Enter; so at the point when you copy it to the clipboard, it's not a shortcut that can be pasted.

Something like that.

Ok thanks. At least it lets you bookmark the site 1st, then find it on the list, then it lets you paste a single 'ordinary looking' shortcut to the desktop or wherever you want them saving. I'll just carry on doing that. It ain't a major problem! But just thought there'd be a simple way like with IE.

I'm not sure whether to start a new post off for another annoyance? Unless you can throw in a quick solution.. Again, it's a problem with firefox browser in that when i delete private data it does delete cookies, cache, saved passwords & more.....but it doesn't delete browsing history. So that means all the sites that have been visited ever, still remain on the dropdown list where you type the address. The correct options have been chosen, but it still refuses to erase the url list. It USED to! but stopped working 2 months ago. I've uninstalled & reinstalled firefox but the problem still persists. There are no trojan's, virusus or spyware on the pc so i'm bemused by this! Do you know the answer? If not a quicky, then do you know where to navigate to in 'regedit' to manually remove the url (history list)? Also, in the ' show history' panel, ther is never any history shown, at any time! This is weird man! Ta

Please mark this thread as SOLVED.

With regard to your second question, I saw this phenomenon but after I installed the Hide Unvisited add-on. after clearing private data, the browsing history was removed from the URL drop down. Firefox 3.0.6