0

I recently formatted my laptop HD and installed a nice fresh copy of XP Pro, it was running XP Home before. However, everytime I boot it now it asks me to choose if I want to launch Home Edition or Pro. How can I stop it from asking me this and just boot Pro automatically?

Thanks!

3
Contributors
7
Replies
8
Views
11 Years
Discussion Span
Last Post by just_a_nobody
0

Hi,
Have you installed Windows XP Pro in the same partition where Home Edition was present? Or, is Pro present in different partition.


What happens if you choose the option "Windows XP Home" from the boot menu?


If you are sure that you have installed Pro over Home, then you can edit the boot.ini file to remove the entry corresponding to Home Edition. This page ( http://vlaurie.com/computers2/Articles/bootini.htm ) describes how to edit Boot.ini file in Windows XP. ( Scroll down to the section named How to Edit Boot.ini Files)

0

I will try booting in XP Home and see what happens.

As for being sure I installed it in the same directory as Home, I deleted all the partitions on the hard drive, then formatted a new one for XP Pro. XP Pro was the only partition on the drive.

*EDIT*

Just tried to boot in Home Edition, get an error message saying "Windows could not start because of a computer disk hardware configuration problem.
Could not read from the selected boot disk.........yadda yadda yadda"

0

Sounds like your Boot.ini file still has a reference to the xp home edition.

Go to Control Panel/Folder Options/View and check Show hidden files and folders and then uncheck "Hide protected operating system files" then click ok. Then open My Computer and open C: and look for the boot.ini file. Right click it and choose "Open with" and choose Notepad. Then just highlight and copy then come here and paste. It should look similar to this, but yours will look different:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Home Edition" /noexecute=optin /fastdetect

0

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect


Guessing I should delete the Home Edition line?

0

Ok, now rename your old boot.ini file as boot.in-old, then in notepad, delete this line, multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
and save the file as boot.ini

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.