0

Hiii


I'm going to document a very frustrating issue I've been experiencing here, and I encourage you all to read it and give any advice you can. I would really appreciate that, a lot. You'll understand after reading...


I recently bought a new laptop, for $3000 -- the XPS M1210. By recently, I mean in the past 2 weeks. I received it 2 days ago. It came pre-installed with Microsoft Media Edition 2005 - a very nice operating system, though I prefer Linux so my first intention was to install the second operating system and set up my laptop for dual-booting. I've done this several times before with desktops, so thought it would be straight-forward.

My laptop came with a lot of features. Internal WiFi and Bluetooth, a 5-in-1 memory card reader, built-in webcam and mic, dual processor, 2 Gigs ram, 120 Gig hard-drive, DVD/CD +/- RW optical drive, media control buttons, and more. You can tell it was a huge investment for me.

So the adventure began, I wanted to steal some space from the massive windows partition to use for my Linux installation. By "some" I mean 70 Gigs, and leave 30 for windows. The rest of the hard-disk is devoted to the Dell Diagnostics Utility and Media Center.

I tried with Partition Magic 8.0. It rebooted, and when the script would usually kick in, an error was displayed instead: xmnt2002 program not found - skipping AUTOCHECK and then it would boot. That frustrated me. I tried again, this time unhiding the partitions using grub before booting. Still, same error. So, partition magic was not going to work.

Next I decided to try to go to the Linux installation directly, and use the YaST utility to resize my windows partition. I tried, but that failed as well. YaST gave me the "Failed to resize partition. The Installer will now exit" error each time I tried that. So, the Linux-rout failed as well.

By now I was quite frustrated. I decided to re-install Windows from the disks I had been provided, deleting the windows partition using the installation menu and re-installing it on a smaller portion of the unallocated space. Windows was installed using the same about of space as the first installation -- It did not allow me to resize it's disk usage like I had planned. So, I lost all the software, but no matter, I reinstalled it all in a few hours, then attempted to resize my partition again.

Failed.

That time, I decided to go the Linux rout -- I deleted the partition using YaST, and installed Linux there using Logical partitions - which worked just fine, and I left 30 gigs unallocated for Windows. I planned to use the Windows installed on that unallocated space later, and then everything would be just dandy. I installed Linux using ogical partitions on an extended partition, so there would be room for one more Physical Partition making four in total, as there is only room for 4 physical partitions.

So I tried that. After preparing Linux, I started the windows installer, selected the unallocated space and pressed 'c' to create an empty partition. I then selected it to have Windows installed there, and the installer asked how to format the partition. I choose NTFS file system. It then proceeded to the format screen, and died on me. I got an error like, "Windows was unable to format the selected partition. The disk may be damaged." It then restarted my computer, and instead of the Grub boot-loader I was greeted with a "Invalid Partitions" screen...

*Screaming inside by now*

SO I ran the Dell Utility and it reported that my hard disk was fine, everything was running 100%. Thank God nothing was damaged -- only my partition table had become corrupt. I tried and tried to fix it. I used utilities to recover it but they failed because they wanted money. It was revealed to me, though, that 2 of the partitions were set as active -- maybe that's why I got the "Invalid Partitions" screen, but I don't know why Windows failed in formatting the unallocated space.

I finally booted from the Linux install disk again and choose to "Update System" which fixed my Invalid Partitions problem, by reinstalling the Boot Loader I assume.. Pheew for that.

I then tried installing Windows again, and received the same error. I even tried with a different format option, but it still failed. So here I am, unable to reinstall Windows because it keeps corrupting my partition table, and I can't get Linux to run properly (yet) with all my hardware, so I have $3000 of computer sitting in front of me that is completely USELESS.

I'm at a loss. I will record a video of what I do to install windows and the exact results of that IF requested. That way you can see the actual error messages, if it's necessary. Otherwise, I've searched and I can't find the help I need. If anyone could help me to install Windows and retain Linux successfully, I would be eternally grateful. I've even been praying about this - that's how much it upsets me, and I just want it to work.

Once again, any help or explanation would be greatly appreciated.
Thank you. :sad:

2
Contributors
2
Replies
3
Views
11 Years
Discussion Span
Last Post by Cudmore
0

Hmm....this really is a longshot, but have you tried contacting Dell. Not usually, but they help sometimes.

Other then that, I don't know what else to tell ya, otehr then wait for somebody else to say something else.

Just so you know' I've placed a copy of this into the Linux forum as well.

Thanks.

EDIT: Here's the other one: http://www.daniweb.com/techtalkforums/thread54738.html

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.