0

I've embedded midi files on a number of pages on one of my sites http://www.rays-sxm.net but when I want to open one of these pages I get a Windows IE info message:
Click to run an ActiveX control on this webpage
I click on OK and nothing happens.:sad:
The message disappears, I can access the page but no background music.
An embedded MP3 file plays OK, though.

HELP,
Ray

3
Contributors
4
Replies
7
Views
10 Years
Discussion Span
Last Post by MidiMagic
0

Ok Ray, I've found the solution to your problem.

Your problem isn't your browser, it's the source code in the page itself. I was viewing the source on your webpage and the backround midi is set to src="/il2/sxm/midis/peanut10.mid" The way your page is setup, it looks like your url http://www.rays-sxm.net forwards to an angelfire member page. When loading your webpage's main page(http://www.rays-sxm.net) its trying to find the midi file in the directory http://www.rays-sxm.net/il2/sxm/midis/peanut10.mid This does not exist because when you use a URL forwarder, it ONLY forwards the url to one file, which in this case is your homepage. The solution to your problem is this: set the url for the source of the midi file on (http://www.angelfire.com/il2/sxm/index.html) to src="http://www.angelfire.com/il2/sxm/midis/peanut10.mid" That will fix the problem and will allow your midi file to be accessed. The reason the active x control comes up anyway is because the source code "<embed" tells internet explorer to open up an object so it can play the file.

Check the source on all your other pages that contain midis and make sure they all point to "http://www.angelfire.com/il2/sxm/midis/" instead of "/il2/sxm/midis/peanut10.mid"

let me know how it goes. ;)

0

Thanx Monte,
but that didn't work. The midis have played on my laptop w/o the http://www.angelfire.com preceding on the index.html page.
I don't have QuickTime on the desktop but have it on my laptop where it plays the midi files.
Ray

0

on my computer, quicktime doesn't play the midi files.. god knows why.. on my laptop it plays through windows media player perfectly

0

Maybe you have to be registered or logged in to their service to be allowed to play the file.

Also, for a MIDI file, the soundcard must have a sounder included. The sounder driver must be installed and enabled, and the browser must be told which driver to use. If any of these are missing, you won't hear anything.

Be aware that each computer will play the MIDI file differently, using the sound samples that came with the soundcard. So what sounds good on one computer can sound quite awful on another. Note that not all soundcards can download samples.

I ran into this problem when I composed a piece using the synth drum sound. One of my soundcards has a 12-note-per-octave (chromatic) scale of synth drum sounds, and the song sounded good. The other one has a 24-note-per-octave (quaretertone) scale for the synth drums, and it sounds awful. I had to change it to steel drums to get it to play universally.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.