0

hi ive recently formatted my computer with 2 windows xp installed on different drives... one was on a C drive and the other one was on E.. i have 2 hds and i halved both of them so all up i have C,D,E,F drives... when i formatted my computer i decided to delete 2 partition [C,D] on the same hd,format it and make just one drive out of it: C. when i finished installing windows xp on C i cant access the windows xp on drive E because of the new boot.ini wont allow me to.

Now... my real problem is.. how do i add the one in drive E to the boot.ini and make it appear everytime i reboot my computer.

do i make sense? >.< anyway any help would be appreciated.


// intrikate01

4
Contributors
12
Replies
13
Views
10 Years
Discussion Span
Last Post by intrikate01
0

uh.. I'm not quite sure what you're saying, but it sounds like you want to edit xp's boot.ini. You can do this very easily edit by going to the root directory of your primary partition.. sounds like your c: boot.ini is located here, simply double click it and write a second entry modeled after the first... you have to know which hd and partition. It will prolly look somethn like this:

multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

0

Yep, that will work [the name in inverted commas is the name you will see on the boot menu: change it to suit]; you can also start recovery console and type:
bootcfg /rebuild -windows will scan the volumes looking for installations; it will ask you if you wish to add them to the boot menu and to name them also...

0

well what i want to do is i want to be able to access the other windows xp installed on another drive... except eversince i formatted my computer the new boot.ini only has 1 xp on the list which is the default one...so, i want to add the other one but i dont know how to make the path refer to the xp in my E drive.

i tried putting this:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT - it didnt work

but i was told that if the os is in the same drive the only variable is partition (x) so i want to figure out which variable i change to make it refer to windows xp in E

Having said that i tried:
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

as well as
multi(0)disk(1)rdisk(0)partition(2)\WINDOWS="Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT

and none of them worked =S

0

hmm i think ill try gerbil's suggestion and see if it works... sounds like it will :cheesy:

thanks for that. brb

0

er... i think you will need:

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Other, surplus? cos I don't trust Windows OS" /noexecute=optin /fastdetect

...or something like that... which assumes that C: is on partition 1 of your first disk, that E: with the other OS is on partition 1 of your second disk.

0

yeh i tried the recovery console and it worked... =S that way wouldve been easier though.

oh well its fixed now so thanks heaps.

0

yep yepp.


boot.ini:

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Windows XP BACKUP" /noexecute=optin /fastdetect

0

Ahah! So E: is not the first partition on your second HD! I was going on you having C: on disk0, and E:, F: on disk1, with the second OS on E:. Obv you have D:, E:, F: on disk1. Good-oh, I misread your info...
Thanks for the feedback.

0

The problem is that, when you combined C: and D: into a single drive, it changed the drive letters on the second drive (and all higher drives). The BIOS always uses the lowest available drive letter for the next drive or partition it finds. It makes this setting every time the computer boots, using the drives it actually finds.

Instead of being the E: and F: drives, your second drive partitions are now D: and E: because the old D: drive is gone.

So you need to change the boot program settings to boot from D: instead of E: for the second drive.

Your CD drive has also been relettered, probably to F:.

Check all of your .bat files and shortcuts. They may also try to access files on the wrong drive. If one fails, just open the properties and change the drive letter to the next lower one.

0

yeah, midi, i got confused with the course of events in his initial post.... his disk 1 actually has xp on the second partition, E:; I thought I read that it was on the first partition...[E:, before he combined c and d...] Arrgh... never mind... thanks... :), sorted me out.

0

yeh lol.. if only i knew how to explain it clearly =S but you guys are good at solving these problems so it didnt matter hehe

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.