0

I have a big problem.

I've got a work laptop which is not booting up telling me it needs the file c:\windows\system32\bcmlogon.dll.

I can't boot into safe mode as it needs the networking element to log in, and starting in safe mode with networking throws up the error.

does anyone have the file they can send me, and I can put it on the hard drive.
Cheers all.

2
Contributors
7
Replies
8
Views
9 Years
Discussion Span
Last Post by uniquestar
0

Try gping into Safe Mode without networking and go back to your last system restore.

otherwise we'll have to find a registry edit to do in Safe Mode (I think).

0

I wish you'd be more specific -it's so frustrating. We're here and you're on the PC in question./

Exactly what does it mean " the system won't log me in"? Same error? Or it won't accept your own credentials? If it's not the original DLL problem in Safe Mode, log on as Administrator without a password.

If you can do that, edit your registry (after saving it via File/Export/Entire Registry) by navigating to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

and deleting the GINADLL key. This is a fairly well reported and documented problem so if you're not infected, one of the solutions offered ought to work.

The consensus on the web seems to be that Broadcomm Wireless adapter is involved here.

0

Right -

Safe mode with networking brings up the error (I agree with the broadcom analysis).

When I boot up intp safe mode it refuses my credentials. I had a problem a while ago and the only way I could log into safe mode was with networking active.

I can't find log in as administrator into safe mode - again refuses with blank passwords and the standard ones that my company uses.

Thanks for all your help, but it seems that I will have to give it to the tech guys at work. I spose they can use a boot disk of somekind and restore the PC.

0

Yeah - the work guys will prolly ghost restore the HDD to standard form.

It makes sense now that you can't logh on as Administrator. They've changed the passowrd and you possibly never had Admin priivileges anyway.

Best wishes

0

Sorry for the late reply, but I thought I would let you know what happened.

The guys here logged into safe mode and tried to delete the GINA DLL reg key, as mentioned in other places on the web. The key wouldn't delete.

They then found that my profile had corrupted, so no chance of grabbing any data from the HDD.

Solution was a re-image of the hdd, and the loss of all data that wasn't backed up.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.