0

Hi,
We have to migrate W2K3 64-bit from W2K and it seems SQL Server 2000 (32-bit) XML services is not working on 64-bit OS.
The url is something like that:
http://64bitserverIIS/APPL/TEMPLATE/userList.xml

The error message is herebelow in IE:
%1 is not a valid Win32 application.

I could not find the reason. Nobody says anything. I don't know what I should check exactly.

We setup W2K3 on another machine as 32-bit. SQL Server 2000 XML services is working. I checked following dlls related to XML services and they are same in both servers:

sqlxmlx.dll
sqlisapi.dll
sqloledb.dll
w3isapi.dll

Does anybody give me a clue to find a solution?

Best regards,

Elif

2
Contributors
2
Replies
3
Views
9 Years
Discussion Span
Last Post by eee25
0

Elif
Did you ever find a solution to this problem? I have the same issue and can't find it mentioned anywhere else.

Lee

0

I run XML services on another W2K server's 32 bit IIS. But I found two solutions. The links related to second solution is herebelow:
(But I did not try!)

Windows Server 2003 SP1 enables WOW64 compatibility for 32-bit Web applications in IIS 6.0
http://support.microsoft.com/kb/895976

Running IIS 32-bit Applications on IIS 64-bit
http://blogs.technet.com/mbaher/archive/2006/12/17/running-iis-32-bit-applications-on-iis-64-bit.aspx

HOWTO: Diagnose One Cause of "%1 is not a valid Win32 application" on IIS6 on 64bit Windows http://blogs.msdn.com/david.wang/archive/2006/06/27/HOWTO-Diagnose-One-Cause-of-1-is-not-a-valid-Win32-application-on-IIS6-on-64bit-Windows.aspx

good luck!

Elif

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.