0

All of my shortcuts do not work, and all of my programs will not launch even when I double-click the exe file. Windows always asks what program I want to open the files with. When my computer boots up I get asked which program I want to open my start up programs with...they are all .ink files. Even when I run Explorer.exe from the task manager it asks me! So, something has gone quite wrong. I did a little "Spring cleaning" and I deleted a lot of crap from my registry (stuff that I'm sure was safe to delete) but after restarting my computer, this stuff started happening. Regedit no longer opens (as I've mentioned, Windows asks me which program I want to open it with) so I can't manually inspect it, and of course none of my repair programs are able to start. I'm actually quite shocked that I was able to get online - the IE icon doesn't work, but I was able to get a browser window open by double-clicking a html file that I had on the hard disk. I should also mention that I defragged my C: drive with Norton Speed Disk, and it could have been that which made a cock-up of everything, because it was the last program I ran before restarting the computer.

Does anyone know what I can do? Keeping in mind that exe files don't work, and regedit doesn't work.

I think this calls for a total re-install...*sigh* GOD I hate re-installing Windows! :sad: Luckily I have a copy which has been slipstreamed with the latest updates etc, so it won't be so bad this time round...but I'd really appreciate if someone could thik of something! lol

P.S Via My Computer, I can access the file types settings, and I tried re-associating programs and files, but the programs that I assopciated the files with also need to be associated with something, which left me kinda stumped...

:sad:

5
Contributors
7
Replies
8
Views
12 Years
Discussion Span
Last Post by DjLizard
0

Don't worry about replying to this any time soon, I just re-installed the bleedin' thing. An eventual reply would be good though, incase someone else comes along with a similar problem who has more patience than I did! hehehe

0

Thanks for the reply ;) I've been cleaning my registry in the same manner for years and never had a problem like this before, but I wouldn't say that qualifies me as an "advanced, knowledgable" user hahaha. But having said that, an advanced user isn't just born with a great understanding of the registry, we all have to learn from the bottom up. If anything these little mess-ups teach me to have more respect for the registry lol I won't even tell you about my first exploration of the registry back in the old days...that was embarrassing...and it wasn't even my computer hahaha...

Thanks again, that link looks like it would have been useful...pity I was too impateint!

:D

0

Any one considering an In place upgrade (Refresh install) should also consider two things:

* You'll probably have to reinstall Updates afterwards and...
* You need to disable File Encryption first if it's turned on. Losing all your data files is a big piss-off!

0

Hi, I thought I would add some information that may be related to this issue... I am working on a PC from an associate with similar issues that appear to have derived from a virus... Most File associations have been removed from the registry(exe, com, lnk, bat, vb, reg, etc)... The File Association tool buttons are all grayed out preventing me from adding any associations... The Registry can be started from a cmd window via Task Manager file/ctrl / new task but it can not be edited. I tried a complete system repair (in place upgrade) similar to the above suggestions but to no avail, problem still exists... I have been searching the internet for days trying to find someone that has run accross a solution for this issue without having to blow away all of the existing data, applications, etc. but have yet to find anyone that knows the virus name or the solution to the problem... Thanks for listening... DaddyDe

0

Dial-a-fix medium can help. It has a function in its Tools dialog (the hammer button) called Repair permissions that often fixes this problem (the associations are usually messed up because there is insufficient priviledges on HKCR and its sub-keys). If that doesn't work, or it alleviates only part of the problem, then get my Repair Associations package, which is further down on the Repair_Permissions page:
http://wiki.djlizard.net/Repair_Permissions
See also:
http://wiki.djlizard.net/Dial-a-fix_tips#Registry_permission_issues

Half the time, this is caused by Norton 2006 products, and the other half is split between malware and general registry damage.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.