0

I am running Vista Home Premium 64 bit. I have 2 files that I was having trouble doing work in, so I tried to delete them. At first they deleted as normal. I clicked on the file, then delete, then yes for the confirmation. For some reason, the file stayed on the folder tree. Thinking I may have missed something, I tried again. This time it says the file no longer exists in that location. I checked the recycle bin, its not there either.
To make matters worse, I can't rename it, move it or change it. Every time I try, it keeps reverting back to the original name and location

I checked the properties. Its not listed as a hidden file or read only. It shows as having 0KB. If I do a complete computer search for the file, it doesn't show up. I've done a system restore to a few days prior to the problem, and its still there. Has anyone seen this type of problem before, or do I have Gremlins in my computer.

12
Contributors
15
Replies
18
Views
8 Years
Discussion Span
Last Post by Recruiter
0

I've had that problem. It may be annoying but just live with it ;). Just try again, I think eventually I got 'em to delete, or I just forgot about them. either way my problem was solved :)

0

I've had that problem. It may be annoying but just live with it ;). Just try again, I think eventually I got 'em to delete, or I just forgot about them. either way my problem was solved :)

Unfortunately, it is an annoying problem. The file names are descrptive, but very similar to other files that are often used. They were created, originally, to hold similar, but slightly different sets of data, in sequence. I need to be able to reuse the folder names, to keep the sequence in order, but can't. That's why I am trying to find a solution.

0

Have you tried saving a new file in the same location with the same name? And then deleting the new file?

0

Try doing a Shift+Delete.

i.e.
1. Select the file/folder.
2. Hold down Shift and press Delete.
3. You'll get a message asking if you want to permanently delete the file.
4. Click Yes.

Post back if that worked/didn't work.

0

I've had the problem on my Vista machine a few times as well. Have you emptied the recycle bin?

If you have, then the file is really deleted, but windows is just showing the place holder. Try reindexing.

Go to START click in the SEARCH box at the bottom and type INDEX. Click on indexing options, click on advanced, then click rebuild.

You may also be due for a defrag, but I am not sure if fragmentation affects that.

0

have you rebooted the computer since the delete ,i use hijackthis to deleted troubled files .,if you download hijackthis go to tools and direct it to the file in question, not sure if hijackthis runs on 64 bit vista

0

Sorry it took so long to respond.
First, I tried to create a new folder to move the files into, then delete. Unfortunately, the files don't move.
Next, I tried the Shift+Delete. and the files just stayed there. Still no change.

Ultimateley, what I decided to do, and it was a bit time consuming, was to copy the entire folder to dvd, except the corrupted files. Now if anything went wrong I had a backup. Next, I deleted everything I could in the folder. Next, I renamed the folder with the corrupted files, to a new location. The folder moved, but wouldn't disappear. For some reason, I still had a bit of trouble with the program, so I uninstalled then reinstalled the program. I then recopied all the files back in. Then, finally everything worked OK, and the corrupted files are no longer there, getting in the way.

0

For future posts because i know allot of people have this problem. There are a couple ways of going about this. It wasn't clear in the post whether or not this was a file or directory so i will post both solutions. There is no guaranty this will work but here it goes...

First open a "elevated" command prompt logged into the user who originally created the files, it is also important that your are in the directory in which the files/directories are located. Then type either of the following commands into the command prompt:

For Files:

takeown /f file_name /d y
icacls file_name /grant administrators:F

For Directories (will perform action recursively):

takeown /f directory_name /r /d y
icacls directory_name /grant administrators:F /t

The above commands should allow you to now delete these files/directories. If this does not work please post back including any information that was displayed during the command entries. TTYS, Good Luck.
Ref: My Digital Life

0

you can try delete it with a program. maybe try with LongPathTool its for deleting "can't be deleted" files and folders :)

0

use unlocker for that file or folder.

first install unlocker and then right click on that file or folder and select unlocker,

a new window will popup, select kill all process and then ok.

now immediately simply select that file/folder and Shift+Del, press OK.

:cool:

0

This thread dates back to 2008. I suspect the original poster no longer has the problem.

0

Just to let everyone know, as the person who first posted the problem, I have had the situation occur a few times over the last 4 years. Each time, I refer back to this post, and it solves the problem.
The problem has actually occurred 4 times to me, in all.
The first remedy I outlined on this post. It was the long way around, but it worked.
The second time, I used Syqher's remedy to delete a file.
The last 2 times, I used LongPathTool. http://longpathtool.com/ It was able to solve the problem for me both times.
I hope this helps

Edited by Recruiter

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.