0

Well, I have used TortoiseSVN a lot previously in Windows XP, and in previous years, it has always been working well and the context menu never had a problem etc. (Btw, for those that dont know I am talking about the right click menu). Either ways, in Windows 7, I just installed 1.6.10 version of TortoiseSVN, and even after rebooting the system, the contaxt menu for tortoise SVN doesnt appear when I right click a folder! I thought this might be an AMD problem, so I installed the same version, same options on my Laptop with Intel i3 processor, STILL same problem, both of these computers are 64 bit with Windows 7 Home Premium. I dont understand why TortoiseSVN fails to work, I really need to get the version control system up. I tried uninstalling, reinstalling, installing PREVIOUS versions of Tortoise, basically EVERYTHING, it MIGHT have something to do with the service not being registered though, because when I check current services, there is nothing on TortoiseSVN in the list. Can someone PLEASE help me? Thank You!

4
Contributors
6
Replies
9
Views
7 Years
Discussion Span
Last Post by aupadhye
1

I got it working, for some reason, I just did a reinstall of the 64 bit version. and it suddenly worked, this is what happened from beginning to end:

*Installed 64 bit TortoiseSVN - Didnt work
*Uninstall 64 bit
*Install 32 bit TortoiseSVN - Didnt work
*Uninstall 32 bit
*Install 64 bit TortoiseSVN - Worked!

IDK, it is a problem with the latest release though I can ensure you, I would suggest that method if it didnt work, this is on release 1.6.10 btw :)

Votes + Comments
Solved major installation problem in software.
0

I uninstalled and reinstalled twice (all 32-bit) and the menus came back. Thanks for posting back with this -- I almost reverted back to an older version :)

I did submit a message on Tigris' mailing list so hopefully it will be addressed in a future version. My reply is pending approval but its on there.

0

No problem, I am glad that I having a problem managed to help someone else, but ya SVN is really important, at least to me, I MUST.. MUST have a version control system for my projects lol. Well thanks for the time and good luck with your ventures ;)

0

THANKS! WargRider's solution + a restart after everything worked for me. Hopefully this issue will be solved in the next release to prevent such hackery.

0

I also had this problem for Tortoise 1.6.13 64 bit on Windows 7. So as suggested I just ran installer again with repair option and just restarted explorer and it started working. Thanks lot for saving my time ;-)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.