0

I formated drive and partitioned the drive, installed windows xp and is back to it's old self, but if I change bios settings to boot from hard disk as first boot device instead of cdrom (for instaling win xp) I get a "boot disk failer" error. If I have it boot cdrom as first device and hard drive second then restart it goes through start up then to "hit any key to boot from cd", but I do not press any buttons, then it will boot and I can remove disk and still all is good, until I restart, then I have to have the win xp cd in drive. Help????

2
Contributors
15
Replies
16
Views
9 Years
Discussion Span
Last Post by gerbil
0

Hi billy, check in Disk Management that your C: partition [your boot partition] is marked Active.

0

O.k. itsays healthy with (boot) as I typed it, if I right click mouse on it, I have the option to make active, Do I need to do this?. I attached a pic of disk management for you to see. Thanks so much for your help.

0

Yes, Billy, your system partition, C: usually, must be marked active otherwise the code in the MBR will not select that partition as the one to read the loaders from [ and hence ntldr, boot.ini...].
While you are in Disk Management console, remove the Active settings from both Disk 1 D: and Disk 3 H: because they do not have OS's on them. BIOS would not really be looking at them for MBR code because they are not the first Sata disk, or not the Master on the Primary controller if PATA, but still, it is neater.
A bit of confusion courtesy M$: the system partition is the one with the ntldr, boot.ini and other boot files, the boot partition is the one with the OS on it. It is the system partition which must be marked Active. For most folks system and boot are the same partition, C:.

0

ok, before I change this, I do not know why system and boot got seperated, the ethan miles drive is a hard drive for storage for my recording studio only, can I put boot and system on the system drive without having to reinstal?

0

If you just did a normal, out of the box, straightforward fresh installation of XP then your system and boot partitions are one and the same. Just check the the files ntldr, ntdetect.com and boot.ini exist in C: root, there will be others but those three should be there if you are to use C: as the boot loader [ie system] partition. In folder options you must uncheck Hide protected Op Sys files first.

I see what you are saying about the Ethan Miles [C:] partition though. Are you using PATA drives? The Primary and Secondary IDE controlled drives? And is Disk 0 the Master drive via jumper setting? Then Setup would make C: on Disk 0 [Master on Primary controller] the System partition. It would put the OS where you requested it to go... E:?
To get around that you make [by setting the jumper] Disk 2 Master on its controller, copy over those three files from C: and then set E; as the only active partition on your set. Should work. Your system and boot partitions would then be one and the same. No need to reinstall. You would have to modify boot.ini though.
When BIOS starts looking for an OS it checks on the first master disk for an MBR [there is an identical execution code in the MBR on each physical disk], loads that MBR code into memory and that code assumes control, checks your drives for the Active partition and then loads from it the boot sector code [all partitions have the same boot sector code...]. That code then gets ntldr placed into memory; it reads boot.ini, and so on. Your boot.ini would be pointing to E: on Disk 2.

0

No pata drives, disk (0) and disk (1) are regular hard drives ata/ide, and the disk (2) is sata. disk (3) is an internal ata/ide that i use as external in a usb converter that I can turn on and off. Not much on this here situation, I conscidered my self an advance user but never delt with this problem before,,, lol. So before I change anything I want to be clear on your instructions. I dont know what happened with the letter assignment cause "C" is usualy the master like you said. I am not clear on this part......"To get around that you make [by setting the jumper] Disk 2 Master on its controller, copy over those three files from C: and then set E; as the only active partition on your set. Should work. Your system and boot partitions would then be one and the same." I am going to check jumpers while you read,,, again, I can't thank you enough for the lesson and help!!!

Part two
attached is new disk management after jumper settings change. I changed nothing but jumpers until I confirm steps that I am not clear on..

Attachments New_Bitmap_Image.JPG 118.69 KB
0

Noted the new pic.
Ok, going with your last post, Disk 0 will be Master by jumper [or outer if using Cable Select] on the Primary Controller, Disk 3 is the Master [or CS outer] on Secondary, and CDROM the slave?
Fine. Initially, COPY the three files over to E: [leave the originals where they are...], make E: the only Active partition in the whole set, then modify boot.ini in E: to look like this:

[boot loader]
timeout=4
default=multi(0)disk(0)rdisk(2)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

Note carefully the numbers in the ().
The script in " " is what you se on the boot screen, can be anything you like...
If it all fails for some reason you willl still be able to boot with the cd.... :)

0

ok, followed to a "t" but I cant make disk(1) sillybilly's storage, unactive, I did however make active my "E" drive but have not restarted yet,,,, a little nervouse,,,lol.

1

Modify boot.ini by going CP, System, Advanced tab, Startup and Recovery Settings button, Edit - boot.ini will open in Notepad. Modify it and Save.
But yeah, we could get into a lil problem with a mixed IDE and Sata disk set if trying to make the Sata drive contain both System and Boot partion. BIOS will see that IDE Active Disk 1 partition and get lost - you will get an error msg.
It may be that you will have to make C: Active as the System partition after all. The original boot.ini in C: would be already correct.
Can I go to bed now, please? It's 1:30 am here... :(

Votes + Comments
Very helpful to me and I learned something as well..
0

O.K. Bro, this is what I got,,,,, I followed everything you said, and I set hard drive back to first boot, cdrom second, system boots and I get a long pharagraph saying canot load from the device, check your hardware configuration blah, blah, blah. I hit any key to reboot, pressing F8 key, I choose the C drive, next screen I choose normal boot, next screen I click the only instalation listed named, "My Bad Ass Machine", (you said I could say what ever I wanted in the quotes), and this is all without cd in drive. maybe got the wrong numbers of drive (multi(0)disk(0)rdisk(2)partition(1)) wrong? Sorry to bang your head Gerbil!!!

0

Nah, your're not banging my head, billy. This all comes down to how your BIOS treats a mix of Sata and IDE drives, where it puts them in the hd hierachy. BIOSes vary in many aspects whilst overall doing the same thing. Some BIOS put the Sata as first devices ie Disko etc and the IDE come later. Yours seems to put it between primary and secondary IDEs. My BIOS lets me order them for boot purposes. That is something you could check... it could be an entry in the drives page of your BIOS setup, like drive or boot configuration where it asks you which hard disk drive is to be your boot device [the system drive containing the boot files... sigh]. I don't mean the generic boot order page where you select floppy, cdrom or hdd, nor that F8 boot selection menu.
Without that choice it does look like for the moment that you will have to put up with your BIOS demanding that Disk0, whatever it is, contains the system partition. Windows XP Setup is pretty hide-bound, it will make Disk0 the system drive no matter what, even forcing the creation of a primary partition if one does not exist [logical volumes cannot be made system drives], it will always write its own MBR on that disk, and write its boot sector files to a primary partition on that disk, making that partition the system volume.
So...
"I get a long pharagraph saying cannot load from the device, check your hardware configuration" - this is your BIOS reporting that the MBR code could not find an Active partition in the Disk0 partition table. The BIOS went straight to Disk0 for the MBR.
"next screen I click the only installation listed namely, "My Bad Ass Machine"" - then it loads, right? If it did then this bit is correct: (multi(0)disk(0)rdisk(2)partition(1). You just have to set C: as Active. And check your BIOS to see if you can make it boot from the Sata.
Points...
"next screen I choose normal boot, next screen I click the only installation listed namely, "My Bad Ass Machine"" - this is Windows talking to you through ntldr. Ntldr has found and read boot.ini, but I thought the boot.ini on C: was the original... did you put the modified one there also? No problem, just wondering. I should have asked to see the original boot.ini.
If Windows did not load at that point then I got the (multi(0)disk(0)rdisk(2)partition(1) wrong - show me the original boot.ini. If that is gone, then go into Recovery Console using your XP installation cd and run:
bootcfg/list
bootcfg /scan -this searches for windows installations across all your disks
bootcfg /rebuild -this lets you choose to add them to your boot.ini
And show it to me too, please. Gotta learn from my mistakes....

0

Gerbil,
before I read your post, you must have read my mind, I just used a little bit of elimination of elements to figure it out.

([boot loader]
timeout=4
default=multi(0)disk(0)rdisk(2)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

This was correct, it was doing what and where it was supposed to be doing, (of course you knew that, lol), the problem was that the bios was told to load like "1, 2, 3", but the boot file says we have to load "2, 1, 3," so in order for it to exucute and read the boot file it had to load that drive first and instead it was loading it second. I changed the boot device priority, (hard drive, cdrom), but then since I have multiple drives, I hade to tell the bios what drive to load first. Did I make any sence at all in explaining my repair? lololol..... Thank you again so much,,,, I will save this info in my book of fixit's, it's a realy big book!!!

And after all of redoing the cpu, I do not see where I gained anything but a lot more different drives to scatter up and a faster boot up!!!!! And of course I got a computer lesson.
Thanks Again Gerbil.

"It's people like you that have the patience and knowledge, that gives us newbs just enough courage and curiosity to tear a computer up."_Billy E. Pettit

0

Yay!! You got there, and isn't it extra nice when you get there by your own ideas? It is no matter at all that the system and boot partitions are on different drives, as long as you remember that your sys will not start without both of em, and as disk0 and disk2.
On the secondary IDE controller consensus would have you put the cdrom as master on the outer, the other drive as slave cos it is a data drive, but it matters not much.
In the next lesson I walk you through turning a hard drive platter into an impressive shaving mirror. Good luck out there.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.