1

My windows XP got virus infected. I have removed it. But I can't access Task Manager. When I press Alt+Ctrl+Delete it says, "Task Manager is disabled by administrator"

How can I enable Task Manager?

9
Contributors
13
Replies
16
Views
10 Years
Discussion Span
Last Post by tgheller
0

Yes, I am logged in as administrator.
And the virus is completely removed.

0

Open your registry with regedit, navigate to this key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
In the right pane if you have a valuename
DisableTaskMgr with a value of 1 [one], either modify the value to 0 [zero], or merely lclick DisableTaskMgr and delete it.
Close the registry window.

0

Enable Task Manager
——————
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
DisableTaskMgr=0

Enable CMD
-------------
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
DisableCmd=0

he he .. but how to enable regedit... here it is...

Enable Regedit
————–
1. Start> run

reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0 /f

2. Start> run

reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0 /f

0

how to enable regedit?

This can be done with Group Policy editor which has graphical interface.

  1. Run > gpedit.msc (Press enter). Group policy editor will appear.
  2. User configuration > Administrative Templates > System
  3. Double click on "Prevent access to registry editing tools".
  4. Disable this option (Yes, disable. If you enable this option Regedit will be disabled)

To enable CMD:
[LIST=2]
[*]Run > gpedit.msc (Press enter). Group policy editor will appear.
[*]User configuration > Administrative Templates > System
[*]Double click on "Prevent access to the command prompt".
[*]Disable this option (Yes, disable. If you enable this option Command Prompt will be disabled)
[/LIST]

To enable Task Manager:
[LIST=3]
[*]Run > gpedit.msc (Press enter). Group policy editor will appear.
[*]User configuration > Administrative Templates > System > "Ctrl+Alt+Del Options"
[*]Double click on "Remove Task Manager".
[*]Disable this option (Yes, disable. If you enable this option Task Manager will be disabled)
[/LIST]

A lot of other rarely used options are available on Group policy editor.

0

When I do "alt control delete" I get a message:
"Task Manager has been disabled by your Administrator"

I have the following instructions to enable Task Manager:
Click Start
Click Run
Enter gpedit.msc in the Open box and click OK
In the Group Policy settings window
Select User Configuration
Select Administrative Templates
Select System
Select Ctrl+Alt+Delete options
Select Remove Task Manager
Double-click the Remove Task Manager option
And as I mentioned above, since the policy is Remove Task Manager, by disabling the policy, you are enabling the Task Manager

But when I enter gpedit.msc I get an error that says:
"Windows can not find gpedit.msc"

So now what I can I do????

Please help!!!!!

I ran a virus scan, and no viruses detected!

0

labber, XP home does not have gpedit. Go to my post in the first page and apply it.
Or, if you wish, just do this and it will remove the key value involved.
==Please copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixkey.reg, as type "all files", to your desktop; dclick it to run... agree; if it opens in notepad instead rclick the icon [file], choose Open with, Registry editor....

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableTaskMgr"=-
0

labber, XP home does not have gpedit. Go to my post in the first page and apply it.
Or, if you wish, just do this and it will remove the key value involved.
==Please copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixkey.reg, as type "all files", to your desktop; dclick it to run... agree; if it opens in notepad instead rclick the icon [file], choose Open with, Registry editor....

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableTaskMgr"=-

thanks ! i open regedit and followed your trail to [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]"DisableTaskMgr" and just deleted it !!

seems to work fine !! thanks again

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.