0

as per Microsoft; http://support.microsoft.com/kb/929200

After you install Windows Internet Explorer 7 on a computer that is running Windows XP with Service Pack 2, a "Restore My Active Desktop" button appears on the desktop
To resolve this problem, follow these steps:

1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
3. In the right pane, right-click DeskHtmlVersion, and then click Modify.
4. In the Value data box, type 0, and then click OK.
5. Exit Registry Editor.
6. Log off from Windows, and then log on. The Restore My Active Desktop button has been removed.

0

...which is right on the first page of this thread..
I actually deleted my post containing this tip, but threadmaker Odegani caught it and repeated it in his reply. It does work though.

0

Hi,
I have encountered the same problem.I could resolve it as follows.

open "run"
type "gpedit.msc"
goto "user configuration - administrative templates - desktop - active desktop "

click on active desktop, on the right panel double click " Enable active desktop "
in the settings menu click "Enabled"
click apply and OK.

Hope it should help.

0

Using the information provided here, I've created two files to further simplify the process of restoring the desktop to its original state (it has happened to me more than once!). There are two files, one called Run.cmd, and the other restore.reg. These are the contents:

Run.cmd (4 lines):
@echo off
regedit /s Restore.reg
attrib -h -r -s "C:\Documents and Settings\%username%\Datos de programa\Microsoft\Internet Explorer\Desktop.htt"
del "C:\Documents and Settings\%username%\Datos de programa\Microsoft\Internet Explorer\Desktop.htt"

Restore.reg:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components]
"DeskHtmlVersion"=dword:00000000
"DeskHtmlMinorVersion"=dword:00000005
"Settings"=dword:00000001
"GeneralFlags"=dword:00000004

Thanks a lot for all the info, hope this works well for you, just remember to have both files on the same folder.

NOTE: As you may have noticed I'm running a spanish version of Windows, please replace "Datos de programa" with your route.

0

change registry key to 0 instead 272 look like solve my problem
but the problem appear again on the next boot, so i have to change DeskHtmlVersion key again again and again everytime my computer run.

So i created small program to set DeskHtmlVersion to Zero Decimal and you must make it run every time my computer start and make DeskHtmlVersion keep to Zero Value.

I upload this file to rapidshare so download it guys…
Download This File

just follow this step :

1. Download and extrak the arcive, you will see DeskHtmlVersionToZero.exe and you have to make it to run on every time computer start, so follow next step.

2. Copy DeskHtmlVersionToZero.exe to C:\WINDOWS\system32\

3. Type regedit on StartMenu > RUN

4. Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

5. Create String Key, give it name DeskHtmlVersionToZero

6. Fill The Value with C:\WINDOWS\system32\DeskHtmlVersionToZero.exe

7. Restart Computer.

8. To Check it, type msconfig on StartMenu > RUN, goto startup tab, you will see DeskHtmlVersionToZero on your startup program.

9. And Check that Your DeskHtmlVersion Keep in Zero Value.

If u like it please give me comments

0

YOU GUY'S RULE! Thanks so so much the regedit hack worked! Made my life so much easier!

Thanks again!
T

0

Hello all,
I am new to this but felt I had to reply to this post.
There is a very simple 'cure' for this line 65 non supporting action problem as there is with many of these things. Right click the desktop and select properties, click settings, click identify, a large figure will appear on the screen, simply press ok and your problem has been cured.
Hope this works for you as it did for me.
Dave

Worked great. Quick and painless. This one goes in the ole' files.

Thanks

0

heres a quick easy way. ok on the desktop right click then click on properties. click on background then choose the one you want and its fixed. then go on google and pick one you want

0

wait... OMG your joking... i just joined like dave and i was gonna say what he said lol

0

The registry fix dit the job for me, i just edited the cmd file so everything is in one file (not a .cmd + .reg). I also modified the path a litte to make it for better use in international windows versions.

My .cmd file:

@ECHO OFF
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components" /v "DeskHtmlVersion" /t REG_DWORD /d 0 /f
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components" /v "DeskHtmlMinorVersion" /t REG_DWORD /d 5 /f
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components" /v "Settings" /t REG_DWORD /d 1 /f
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components" /v "GeneralFlags" /t REG_DWORD /d 4 /f
ATTRIB -h -r -s "%APPDATA%\Microsoft\Internet Explorer\Desktop.htt"
DEL "%APPDATA%\Microsoft\Internet Explorer\Desktop.htt"
0

The tip given by "gerbil" works perfectly for me. Before fixing this, I had no option but to stare at the sluggish white desktop wallpaper (of active-desktop-error). I was so relieved after this problem was fixed. Thanks a ton for making my life delightful.

0

on the screen is active desktop decivery, i cant het rid of it . can you help. thank you.

0

Hi,
You have posted to a very old full thread. Please start your own thread and tell us the whole story. Information on your PC and details of your problem. when it happens, what happens, what you are doing when it happens and what you have done to get rid of the problem.
There are many good people here who want to assist you but we need information to do that. Like when you go to a doctor, you must tell him your problems, and as we can not see your PC or problem you must be very exacting.
To start a new thread, click on the words "New thread" above where you type your message.

0

Hi there,
I have a small Acer computer in which i cannot locate desktop.htt. I folowed all the steps and searched my c: drive as well as all other places and it says my search cannot be found! And i'm certain the box is unckecked to display them. Any suggestions?

0

Hi,
You have posted to a very old full thread. Please start your own thread and tell us the whole story. Information on your PC and details of your problem. when it happens, what happens, what you are doing when it happens and what you have done to get rid of the problem.
There are many good people here who want to assist you but we need information to do that. Like when you go to a doctor, you must tell him your problems, and as we can not see your PC or problem you must be very exacting.
To start a new thread, click on the words "New thread" above where you type your message.

0

omg i cant take something i can't click on proporties when i try to run some programs it comes u need a program associerat -.- i dont get it . PLEASE HELP MEEEEE:(:(:'(:sad:

0

OKAY for all those out everywhere who suffer from Active Desktop Recovery - "white screen of distress syndrome" , and find no fixes ...
First thing, download Dr.Web CureIT!. ... and run that ...

You will find you have a Virus or Trojan causing the major grief.
[ run in Complete Scan mode after it does the Express scan - which Will take a Lonnnng time ! ] Let it Cure or KILL whatever it finds.
Secondly, Get a decent AntiVirus - such as COMODO Internet Suite .
This is very thorough, with a built-in Firewall and other securities which also monitor hard drive and registry write activity,
and it is also Free ! ...

The Active desktop Recovery mostly is caused by an infected Windows Explorer and whatever droppers trying to propagate ...
SO ,
... once all the scans are finished, and computer re-started - you should now see a normal desktop! ...
Lastly ... and more importantly - do a Full SCAN of ALL your Internal and External Drives and Flash drives - there is a strong possibility of a Boot Sector Virus dropper on any drives which have been used while you have had this problem ... [ and all back-up CDs etc. ]

IF you are on a network, ISOLATE ALL terminals and scan each ...
IF there is problem over a large network - I notice DrWeb now also Sell a Network version of their CureIT which might be the only solution ... ... ...
HOPE this will resolve your White Screen of Death syndrome ...
I have just had to do this on several computers recently ...

0

Wow!! you were hot on the job, Oded!! Glad it worked... however i edited that post to provide what i consider to be a better fix, a true one, involving deleting any old desktop.htt files and letting windows create a new one.. The edited post has a fix which is a proper fix, not a hash job to tide you over. Explorer would rebuild a compatible desktop.htt file. Cheers..

This was not a better fix. I deleted desktop.htt 3 times with no success.
The registry trick was the fix for me.
Thx

0

Thanks, Gerbil. This clinched it! I have no idea what this means or what other 'side effects' are associated with this change, if any. However, at this point in time it works again!
Thank you so much!
Oded

Ditto Gerbil...just had to refresh the desktop after applying fix and Presto.. Nice one ;D

Edited by muireanb: n/a

0

1.Go to Run and type regedit
2.Now navigate to this path – HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
3.You would find a key named DeskHtmlVersion
4.Right click the key and select Modify
5.Under the label Base, select the radio button Decimal
6.Change Value data to 0
7.Click OK
8.Restart

0

As on Page 1. Glad it worked for you. I posted the desktop.htt deletion method because some people would be more comfortable with that. But in some cases it does not work. The regedit I gave to the OP in the first case [and then removed] seems to work in all cases:-
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
Change the value of DeskHtmlVersion to zero instead of decimal 272.
Cheers.

Edited by gerbil: n/a

0

Active desktop restore
I re-booted my XP Home based computer after shutting it down normallty and received the whire screen with the message:


plz help me.

0

I tried looking for destop.htt and doing your suggestion. I did a search without any results. I have the same error message and my computer will not let me change the background or restore active desktop. any other suggestions

0

Hello, matt. Your search for desktop.htt will not work if you do not go into Explorer > Tools > folder options > View tab, and elect to show protected operating system files.
What was the result of doing this : "The regedit I gave to the OP in the first case [and then removed] seems to work in all cases:-
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
Change the value of DeskHtmlVersion to zero instead of decimal 272.
Cheers."?

Edited by gerbil: n/a

0

:'(it doesn't work, problem is still the same!!! i tryed to delete desktop.htt and refresh the desktop, but there are no positive results!!

0

For some, this works: Go into Explorer > Tools > folder options > View tab, and elect to show protected operating system files. Search for your desktop.htt and delete it; restart your computer.
If that does not work, then modify this key as shown:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
Change the value of DeskHtmlVersion to zero instead of decimal 272.
If you are uncomforatable about entering the registry because of all the hoodoo stories...
Please copy the text in the box to a notepad [format/wordwrap unchecked] and save as fixkey.reg to your desktop; dclick it to run... agree; if it instead opens in notepad then rclick the icon [file], choose Open with, Registry editor.... or Merge.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components]
"DeskHtmlVersion"=dword:00000000
0

Thanks Gerbil,

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components
Change the value of DeskHtmlVersion to zero instead of decimal 272.

It works for me!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.